Get in touch
Back
Maintenance

Etivity Upgrade to 5.33

Completed 29 May at 01:00am AEST.

Etivity Web Portal Etivity Login Tambla One Tambla One Logon Secure File Transfer Service etivity.tambla.net Logon
Completed

Maintenance completed

Posted 29 May at 01:00am AEST.
Started

The Etivity SaaS will be upgraded to the latest build 5.33 on 28/5/2025 starting at 9PM EDST and finishing on 29/5/2025 1AM EDST.
During this time the service will be unavailable to use.

Posted 28 May at 09:00pm AEST.