Back
Maintenance

Etivity Version Upgrade
Completed 20 Apr at 01:00am AEST.
Etivity Web Portal
Etivity Login
Tambla One
Completed
Maintenance completed
Posted
20 Apr at 01:00am AEST.
Updated
The Etivity upgrade process commenced a 9PM. Etivity will be unavailable till 1AM.
Posted
19 Apr at 09:28pm AEST.

Started
The Etivity SaaS will be upgraded to the latest build 5.29 on 19/04/2023 starting at 9PM EDST and finishing 1AM EDST.
During this time the service will be unavailable to use.
Posted
19 Apr at 09:00pm AEST.